**Bella for SketchUp** Version 20.15 [Bella for Rhino](../bella_rhino/index.html) | [Bella for Maya](../bella_maya/index.html) | [Bella for SketchUp](../bella_sketchup/index.html) | [Bella GUI](../bella_gui/index.html) | [Bella CLI](../bella_cli/index.html) | [Bella Core](../bella/index.html) | [Tutorials](../../tutorials) | [Node Definitions](../nodes/index.html) | [Main site](https://bellarender.com) | [Forums](https://bellarender.com/forums) Introduction =================================================================================================== Bella for SketchUp is a simple exporter plugin for SketchUp 2017 and up. It allows setting up the Bella scene & materials, which are then exported to a Bella file and rendered using Bella GUI. ## Scope This document intends to explain specifically about Bella for SketchUp, not about general Bella concepts, for which you should refer to the [core Bella](../bella/index.html) and [node definition](../nodes/index.html) documentation. For information on Bella licensing, and how to install your Bella license, see [Licensing](../bella_gui/index.html) in the Bella GUI documentation. Installation =================================================================================================== To install Bella for SketchUp, download the package appropriate for you operating system (.zip for Windows, .dmg for MacOS) and follow these steps: ## Windows 1. Download the .zip file and unzip it on your desktop. 2. Start SketchUp and click *Window > Extension Manager*. 3. Click *Install Extension*. 4. Browse & select the unzipped `bella_sketchup--win.rbz`. 5. The Bella toolbar should appear (if not see *View > Toolbars*). !!! If you encounter any error when attempting to start Bella GUI, download and install Microsoft Visual C++ runtime from the [downloads page](https://bellarender.com/downloads). ## MacOS 1. Download the .dmg file and double-click to mount it. 2. Start SketchUp and click *Window > Extension Manager*. 3. Click *Install Extension*. 4. Browse & select `bella_sketchup.rbz` in the mounted .dmg. 5. The Bella toolbar should appear (if not see *View > Tool Palettes*). Settings =================================================================================================== To open the Bella Settings window, click the 'gear' icon in the Bella toolbar: ![](toolbar.png) The Bella Settings window will be shown (or hidden, if it is already visible): ![](settings.png) Using this window you can set up the Bella environment, camera, and materials. ## Environment ![](environment.png) ### Type One of four environment types may be selected: Type | Description ---------------------|-------------------------- Color Dome | The scene will be illuminated by a dome of light, with color set by the current style. Sky Dome | The scene will be lit by a physical sky simulation, according to the SketchUp date & time. Image Dome | The scene will be lit by an HDRI image. None | There will be no scene illumination. ### Sun The sun may be enabled or disabled explicitly, or set according to the current SketchUp shadow settings, by using the *Auto* mode. ### Ground plane The Bella ground plane will be enabled or disabled according to the current SketchUp style. ## Camera ![](camera.png) While the physical attributes of the camera are taken from SketchUp, this section allows for setting up depth of field (DOF), exposure, and focus distance. ### F-Stop The *F-Stop* controls the depth of field of the shot, where lower numbers will decrease the distance between the nearest & furthest in-focus points. Because the Bella camera is set to compensate exposure, this may be set arbitrarily without needing to also adjust exposure. ### EV The *EV* (or *Exposure Value*) is a number characterizing the exposure of the shot, where higher numbers will be appropriate for brighter environments, and vice versa. See [here](https://en.wikipedia.org/wiki/Exposure_value#Tabulated_exposure_values) for some common values. ### Focus dist. Lastly, you may either set the *Focus distance* manually, by picking a point in the model, or you may click *Auto* (this just sets the value to `-1`) to have the plugin compute a suitable distance. ## Materials ![](materials.png) ### Types In this section of the panel are listed all the materials in the model, allowing you to assign to each a chosen Bella material type: Type | Description ------------------|-------------------- Auto | The plugin will try to guess an appropriate material according to SketchUp color, opacity, etc. Lambert | This is a perfectly diffuse material. Metal | This is a metal material, with adjustable roughness. Ceramic | This is a ceramic material, with adjustable roughness & specularity. Plastic | This is a plastic material, with adjustable roughness & specularity. Urethane | This is a rubber-like urethan material, with adjustable translucence & roughness. Water | This is a water material. It is a true dielectric, so should only be used on geometry with volume. Glass | This is a glass material. Like *Water* it should only be used on geometry with volume. Sheet | This is a glass-like material which has no refraction, and is suitable for things like windows. Emitter | This is an emitter material, which allows creating lights from geometry. ### Notes Material settings not exposed in this table (e.g. color, texture) are taken from the associated SketchUp material. !!! warn Bella does not support emitters assigned at the sub-object level, so you should only assign emitter materials to groups or components, which have no per-face material assignments. !!! Clicking on materials in this table will select them for editing in SketchUp's material panel. For more information on the specific material types, see the [core Bella](../bella/index.html) documentation. Rendering =================================================================================================== Rendering in this plugin currently involves exporting the model to a Bella file, and rendering that file in Bella GUI. To export, just click the *Render in Bella* button (the one with the Bella logo): ![](toolbar.png) The plugin will export a Bella file and open Bella GIU, which will start rendering: ![](rendering.png) You may stop the render and change any parameters you wish, save the file, render again, etc. For more details on this see the [Bella GUI](../bella_gui/index.html) documentation.