Bella GUI / OS X Catalina

Forums Bug Reports Bella GUI / OS X Catalina

  • This topic has 5 replies, 2 voices, and was last updated 6 months ago by Jeremy Hill.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #4429
    PhilipPhilip

    Hi guys! Now that we have a functional Rhino plugin I’ve done some testing in Bella. I noticed that stopping a render and/or closing Bella GUI (cmd + q) takes a very long time on both my systems (iMac Pro and MacBook Pro) – can be over 5 minutes of “beachballing” before Bella closes.

    Philip

    #4432
    Jeremy HillJeremy Hill

    Are you able to reproduce this by using the default sphere/plane scene?

    My first guess would be that it could be due to the denoiser or bloom/diffraction being enabled. Second guess would be related to rendering at high resolution with the BSI file taking too long to be written for some reason. The confusing part is that you should not get a beachball, so it seems possible to be slow network or such.

    To try to narrow down what may be happening, you can force stopping without denoising/bloom/diffraction/BSI by holding command down when you click the stop button.

    #4434
    PhilipPhilip

    When using the default sphere scene stopping the render takes only a few seconds (before the “render” text turns blue again) – seems normal to me. Closing Bella after that happens without delay.

    Denoiser is on, but diffraction is not enabled. Render resolution is my perspective viewport resolution (4224 x 2624).
    Saving directly to the hard drive – not over the network.

    With force stopping the render stops and I can close Bella without the delay – even if the “render” button doesn’t turn blue again (delay there compared to the default scene) before closing Bella.
    If I’m stopping the render the normal way and then closing Bella, I get the long delay (not always 5 min, though).

    Philip

    #4438
    Jeremy HillJeremy Hill

    That makes a bit more sense, since the denoiser can take quite awhile, increasing with resolution. It may be quite preferable not to enable it until after you have finished rendering; like camera ISO and some other parameters, this can be enabled/disabled during or after rendering, or also after re-opening a file and resuming render.

    I am still not sure where the beachball would come from though, since we have callbacks installed for updating the progress bar in the gui, as denoising is performed.

    By the way, the trick of holding command (CTRL on windows) to force actions also allows skipping confirmation dialogs about overwriting files & image buffers, when starting a render or IPR.

    #4440
    PhilipPhilip

    I disabled the denoiser… and I’m sorry to disappoint you, but disabling the denoiser has no effect… Same symptoms still – including the beachball.

    Thanks for the additional info about the force actions 🙂

    Philip

    #4444
    Jeremy HillJeremy Hill

    Ok, well I’ll think on it and see if I can come up with anything.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.