Bella-test: Day 2. So many questions... :)

Forums General Bella-test: Day 2. So many questions... :)

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1908
    tetsuoo

    Hi,
    So you guys managed to create shaders easier than Corona or Keyshot ! That’s why I’m here today 😀
    I started with the Maya plugin. Almost nothing in the render settings, what a breeze. Add materials, apply, import some HDRI, hit Render. That’s it. Almost. Now this time I push it a bit further… Let’s export to the BellaUI standalone.

    Hierarchy :
    – Is there a way to select meshes directly in the viewport ?
    – No “Collapse All” ?
    – a classic “eye” icon to hide/show a mesh would be nice

    Materials :
    – Can I duplicate a material ?

    Editor :
    – Let’s say I added an element in a mesh shape (why ? because I can), how can I remove it ?

    Console :
    – I’m getting a lot of “thread XX reports floating point error(s), I hope everything is okay 😀

    One last thing, I “exported” my Maya scene to BellaUI, but now I’ve done something wrong and one mesh is invisible. As I couldn’t find out my mistake (the material opacity is at 100%), the easiest way to fix this would be to import again only the mesh I need into BellaUI, without replacing the whole scene. Is that possible ?
    Or maybe I could import the BSX back into Maya and… wait, I can’t do that 😀

    By the way I vote for BSX format, right now my scene is 300MB instead of 615, I love that 🙂

    Side notes about Maya plugin :
    The Blend Material is a bit confusing.
    You can either connect materials in the hypershade or directly create them in the Blend node (in Attribute Editor); but in that case the connections are not visible in the hypershade… in the Hypergraph neither.
    If you mix the two methods, there is no visual indicator in the Hypershade showing that there’s something in there.
    I remembered that back then in Keyshot you couldn’t blend a Glass material with something else (maybe now you can, I don’t know… anyway xD ), so I tried to add a Bella Glass to the Blend and, funny enough, there is no Glass in the list when you add a Material element…. but you can still do it in the Hypershade. Cool. Weird, but cool lol

    maya_hypershade

    The visual update of the connections in the Hypershade seems to be problematic for now, you need to click on the Input icon to refresh… oh well. It’s Beta after all, fair enough 🙂

    Now time to sleep, tomorrow I will try to find out what is that Stack thingy, it totally look like a Blend 🙂

    Later guys !

    #1909
    Jeremy Hill

    Hey, thanks for the detailed feedback!

    Regarding the hierarchy in the gui, indeed that is very simplistic still, but I think all the items you mention are already on the to-do list. You cannot yet duplicate a material (or any node), but that is also something that will be added.

    Regarding the “add element” link in a mesh, that is something that will disappear in the next build; it’s only there because the gui is quite generic, so everything that supports such a function internally, is having it exposed in the current build (and in the case of a mesh step, or some other things, is not really applicable in a gui context).

    Now, on the floating point error reports, I would really appreciate any repro scene, since these can be coming from anywhere, whether in our code, or in third-party code.

    Regarding the invisible mesh, it could be that the parent transform has visibility set to hidden, but if not then I guess I’d need a scene to repro and see if there is potentially some bug. Regarding re-importing, that is another yet-to-be implemented gui feature, and it is also related to, for instance, importing/referencing external scenes, materials, etc.

    Regarding the blend node connections, by default there is a filter active in the hypershade nodegraph:

    filter

    If you clear that, then you should see what you’re looking for, but let me know if it ends up you are referring to something else.

    On the last items, I think the problem is that the “glass” and “water” materials are a special type of material node, so the generic code dealing with material types is probably not filtering things properly — I’ll take a look.

    #1911
    tetsuoo

    Hey.
    Wow I never know about that filter in Hypershade 😀 This totally works now

    I just start BellaUI with my scene again and all errors are gone. No floating point errors anymore neither. My mesh is back too, it’s magic xD I remember trying to fix it but nothing worked before so I don’t know all that happened…. What I can tell though is that my mistake was to play too much with elements; apparently I have added a UV map on that mesh inside BellaUI and couldn’t remove it so as a result it couldn’t be rendered (“[ERROR] mesh ‘[0]’ has an invalid number of UVs”).
    I also tried “Remove Unreferrenced” as a desperate move lol oh well, everything is fine now ^^

    #1912
    Jeremy Hill

    Yes, that error makes sense, since a manually-added mesh step would have an invalid uv count, however I don’t think it could produce floating point errors, so just keep an eye on that to see if it occurs again (there’s a possibility it could come from a third-party library like OpenImageIO, if there was some problematic texture, or similar).

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.