Default materials

Forums Rhino Plugin Default materials

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #4816

    Hi Jeremy,

    Quick question for you – when I do a quick render with Bella, I have noticed a new behavior – Rhino automatically creates default materials for each layer based on the layer color. Is this a Bella thing, or a Rhino thing? I haven’t been doing too many renders in R6, so it may be that this is a behavior that I haven’t noticed before…

    It is relatively easy when it is a new file to simply erase all the materials, but when it is a big complicated model I can’t have materials being assigned randomly, as culling them takes way too long…

    I hope all is well!


    Jeremy Hill

    I don’t think I’ve seen this, so I’ll have to try to reproduce it. It sounds like some Rhino option, but we’ll see.

    Jeremy Hill

    Found it, if you go to the display options for the Bella display mode (view title > Display Options), under Shading Settings it sounds like you have Color & Material usage set to Object’s color (Rendering material will give you what you want). I did not even know this worked, but we get the material assignments from the rhino sdk, so apparently it is taking care of having us obey this setting.


    Thanks Jeremy – I switched it to “render material” and it seems to do the trick!!

    Jeremy Hill


    btw, it is taking a little while, but I am close to having bella materials & textures integrated (with the possibility of using rhino textures in bella materials, and vice versa). We also have some nice improvements performance-wise (mainly regarding startup time, especially when there are lots of instances), and in the case you do any work in the bella gui, I am working on getting nice display names for things, and exporting a hierarchy based on the layer structure (with material inheritance being used where possible).


    Somehow I missed your last post 🙂 – exciting!! Looking forward to trying it out!

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.