FBX import from Rhino

Forums General FBX import from Rhino

This topic contains 11 replies, has 2 voices, and was last updated by Jeremy Hill 3 months, 2 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #3708
    Philip
    Philip

    Hi guys! I exported a FBX-file from Rhino and imported it to Bella. The import was successful (I guess) – all the objects are listed in Hierarchy, but I don’t see my design in the viewport. When I press Render it only renders the default sphere. User error…?

    Philip

    #3710
    Jeremy Hill
    Jeremy Hill

    The default scene is set up for centimeters, so perhaps the model is just out of view.

    With IPR running, you can hold ALT and zoom out with the right mouse button. It is set up to match maya at this time, so on mac it should be ALT+CMD+left for pan, ALT+right for zoom, and ALT+left for orbit.

    By the way, by saying “set up for centimeters” I mean that the world xform has scale factors of 0.01.

    So please give that a try and let me know if it helps.

    #3757
    Philip
    Philip

    I totally forgot about my test – to much work here 🙂 Anyway, I tried again following your advice, but I can’t get my imported model to show up. I started IPR and Bella started rendering the default sphere. Trying those navigation commands is zooming in and out and panning the sphere scene – with a very long lag and the beachball spinning almost all the time – but no sign of my imported FBX model, unfortunately.

    What could I try next?

    Philip

    #3758
    Philip
    Philip

    Something like Rhino’s Zoom Extents could be nice to get the whole scene visible 🙂

    Philip

    #3759
    Jeremy Hill
    Jeremy Hill

    Hmm, it runs smoothly here on my pretty-old and weak macbook pro (13″ 11,1).

    So, let’s try one thing at a time. First, just open bella_gui, enable IPR without changing anything, and let me know if navigating the camera in the default scene gives you beachball & lag.

    If that seems OK, then let’s proceed to import FBX, but just make a simple one for testing, and see how that behaves. If that’s OK, then I’ll request to see the FBX you are referring to above, in case there is something peculiar about it that is producing lag.

    #3760
    Jeremy Hill
    Jeremy Hill

    And yes, we have it on the list to add a few things like zoom extents, pick focus distance, etc.

    #3763
    Philip
    Philip

    Ok, thanks! I’ll have to try that tomorrow – it’s past midnight here in Finland 🙂

    Philip

    #3765
    Jeremy Hill
    Jeremy Hill

    Heh, well buenas noches! 🙂

    #3767
    Philip
    Philip

    I couldn’t go to sleep yet – I had to try… Yes, unfortunately I get the same lag and spinning beachball after just opening Bella, enabling IPR and starting to navigate the scene.

    Continuing tomorrow – Hyvää yötä! 😉

    #3772
    Philip
    Philip

    Allright, now a have some good news (for you) and bad news (for me). As I wrote yesterday, I still got the lag and beachball – on my iMac Pro (which I thought was supposed to be a good machine) – but it works normally when trying the same thing on my little MacBook Pro. The fans are spinning like crazy when I start IPR though, so perhaps not everything is quite optimised yet (or my MacBook isn’t powerful enough)…?

    I wonder what’s wrong with my main (desktop) computer… Do you have any guesses or suggestions, or should I just reinstall the operating system? This iMac is about 18 months old already, so I guess I could try that if nothing else helps.

    #3773
    Philip
    Philip

    However – if I reinstall the OS I’ll do a clean install of Catalina, so I have to wait until Bella is compatible with Catalina.

    #3775
    Jeremy Hill
    Jeremy Hill

    That is indeed very strange, the pro should be a beast, just going by the specs, and there is not anything particularly written to favor one type of system over another.

    It is possible to locate specifically the most recent version of mojave (I think this link will get you there) and install that, if you are not already on it.

    Also, by default, the IPR is using -1 threads, meaning maximum threads minus one, so you might try fiddling with that and see if it changes anything if you keep 2 or 3 threads free, to let the OS breathe a bit more.

    If these don’t shed any further light, we can set up a remote session, so I can take a look and try to get an idea what might be happening.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.